Comms Broadcasting

Major incident Comms
2025-12-01 06:33 GMT · 1 hour, 23 minutes

Updates

Resolved

The issue has been resolved, the team will continue to monitor.

December 1, 2025 · 07:56 GMT
Update

We are seeing signs of recovery as the fix is deploying to each of the regions.

Some users will be able to refresh and begin using broadcasts again.

December 1, 2025 · 07:47 GMT
Issue

We are aware of Broadcast loading failing on the Comms Module. The team are releasing a fix to resolve the issue.

A further update is expected by 08:00 GMT

December 1, 2025 · 06:33 GMT

← Back